SU Podium Forum
Register  |   |   |  Calendar  |  Latest Topics
 
 
 


Reply
  Author   Comment  
atrodler

Avatar / Picture

Registered:
Posts: 229
Reply with quote  #1 
all of a sudden safari won't show my generated html file for a panorama.
i see this only.
Screen Shot 2017-09-26 at 11.39.30 AM.png 


__________________
"adopt the pace of nature: her secret is patience." 
-Ralph Waldo Emerson
bigstick

Avatar / Picture

Moderator
Registered:
Posts: 10,249
Reply with quote  #2 
Is the image file in the same location?

If so, it ought to work...

__________________

That which does not kill us makes us stronger
-Friedrich Nietzsche

atrodler

Avatar / Picture

Registered:
Posts: 229
Reply with quote  #3 
yeah I know. It has been working fine. Just all of a sudden... IDK, weird.


__________________
"adopt the pace of nature: her secret is patience." 
-Ralph Waldo Emerson
JustinSlick

Avatar / Picture

Moderator
Registered:
Posts: 306
Reply with quote  #4 
Hey Andrew are you still having problems with this or was it resolved? 

Panopdm is spread across several AWS servers, and there has been a recurring issue where the temp folder will fill up on one of them and cause these black panoramas.  It's an easy fix if that's the case here.

__________________
What's New in SU Podium?
What's New in Podium Browser?
atrodler

Avatar / Picture

Registered:
Posts: 229
Reply with quote  #5 
I don't think that is the issue in my case. I'm simply running this local. I render the image and then generate the HTML file. Up until now, as long as the HTML file and corresponding pano render are in the same folder, double clicking the HTML file opened the image and safari. I've moved them around on my computer to several different folders with no trouble whatsoever. Now for some reason, any new HTML I generate as well as any of my previous generations, all view as black.
Driving me crazy.

__________________
"adopt the pace of nature: her secret is patience." 
-Ralph Waldo Emerson
JustinSlick

Avatar / Picture

Moderator
Registered:
Posts: 306
Reply with quote  #6 
Oh sorry, somehow missed the fact that this was local html even though it's right there in the title [crazy].

Wow that's odd.  Do you have any other browsers installed? Have you tried in Firefox or Chrome?

__________________
What's New in SU Podium?
What's New in Podium Browser?
atrodler

Avatar / Picture

Registered:
Posts: 229
Reply with quote  #7 
i have no other browser only because i never had the need for any other. i don't know what could have changed. there is a lot of this going on. i don't know if it is relevant to the problem, or normal 'stuff', or not.
Screen Shot 2017-09-28 at 12.09.35 PM.png 

Screen Shot 2017-09-28 at 12.09.46 PM.png 


__________________
"adopt the pace of nature: her secret is patience." 
-Ralph Waldo Emerson
JustinSlick

Avatar / Picture

Moderator
Registered:
Posts: 306
Reply with quote  #8 
OK interesting.  Chrome doesn't allow WebGL from a local file... that might be what's happening here as well since the two browsers use the same underlying tech.  Not sure why it's just now affecting you; maybe Safari updated or something.

I don't have a Mac to try this, but if you go to Preferences > Security, there is an "Allow WebGL" section. Make sure it's set to "always allow" (or whatever it's called in Safari).


__________________
What's New in SU Podium?
What's New in Podium Browser?
atrodler

Avatar / Picture

Registered:
Posts: 229
Reply with quote  #9 
HEY!

There is no longer an 'enable webgl' setting in safari 11 but I did find and check 'disable local file restrictions' in the safari develop pull down menu. you know... just to see and I'm back in business! I don't know if I inadvertently changed it or what but that's brain fodder for another day. thanks for the help.



Screen Shot 2017-09-29 at 9.24.06 AM.png


__________________
"adopt the pace of nature: her secret is patience." 
-Ralph Waldo Emerson
JustinSlick

Avatar / Picture

Moderator
Registered:
Posts: 306
Reply with quote  #10 
Nice, thanks for the update.  That's good to know, nice that it's so easy to find in Safari too.

This was (and still is) an issue in Chrome, and honestly I'm still not sure what the fix is.  I can get them to display bu

Firefox works by default though, if you or anyone reading this ever needs to send a Pano .html file to a non-mac user for local viewing.

__________________
What's New in SU Podium?
What's New in Podium Browser?
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.