SU Podium Forum
Register  |   |   |  Calendar  |  Latest Topics
 
 
 


Reply
  Author   Comment  
TOTO

Registered:
Posts: 87
Reply with quote  #1 
I don´t know why but when I render images in png with transparency enabled and the model has texture colors with opacity not at 100 % it doesn´t appeard the entire object that has the transparency textures (opacity not at 100 %), it is like when the background of the geometry that has the transparency is withou a face behind podium doesn´t recognized the transparence face....what can I do to get my png transparent images complete??


bigstick

Avatar / Picture

Moderator
Registered:
Posts: 10,224
Reply with quote  #2 
I don't understand. Can we have some more information (and with images please) so we can work out what the issue is?
__________________

That which does not kill us makes us stronger
-Friedrich Nietzsche

TOTO

Registered:
Posts: 87
Reply with quote  #3 
ok..this is the issue!!
when I want to render images with transparent background I use the png format....but I have noticed that when I have materials with opacity not at 100% and those geometries or faces have the sketchup background color as a background too podium doesn´t recognize that face..
There is an image to make me understand.....because I don´t really know how to explain better!!!
thanks

Attached Images
jpeg EXPLAINED_IMAGE.jpg (891.25 KB, 399 views)
png RENDER_1_2010-08-21_09311100000.png (1.53 MB, 338 views)
jpeg RENDER_1_2010-08-20_23363300000_alph.jpg (501.80 KB, 256 views)

bigstick

Avatar / Picture

Moderator
Registered:
Posts: 10,224
Reply with quote  #4 
Okay - thanks, now I understand!

I think this is a render engine issue. When you have a transparent background and transparent materials, you will still see through the glass to the background.

What the render engine is doing, is removing the transparent surfaces, so that you can see the background behind. I think this is a case where you need to create a multipass render. I don't think it's a bug as such, I think it is an issue with background transparency and transparent materials.

__________________

That which does not kill us makes us stronger
-Friedrich Nietzsche

TOTO

Registered:
Posts: 87
Reply with quote  #5 
Thanks bigstick now I get it! But when you say multipass render means to make two or three shot so that later I can blend it in Photoshop or something like that?
bigstick

Avatar / Picture

Moderator
Registered:
Posts: 10,224
Reply with quote  #6 
Exactly
__________________

That which does not kill us makes us stronger
-Friedrich Nietzsche

michaliszissiou

Avatar / Picture

Art Master
Registered:
Posts: 1,571
Reply with quote  #7 
Try a clay rendering. Use mask on this. 
@bigstick: A simple B&W (1.7 like) render preset could be a good idea. Using the clay mode. 

Update:
After some tests, clay render keeps showing transparency. Is this right? 
One solution. A second render using non transparent materials... 
Just a moment we have an issue here. Semi transparent materials should be semi visible in alpha export. 
bigstick

Avatar / Picture

Moderator
Registered:
Posts: 10,224
Reply with quote  #8 
Yes, clay render supports both transparency, reflectivity and alpha maps.

I see what you mean about semi-transparent materials, I'll find out...

__________________

That which does not kill us makes us stronger
-Friedrich Nietzsche

akeating

Registered:
Posts: 6
Reply with quote  #9 
Bigstick - was this ever resolved? I have the same issue. Transparent textures show all the way through to the alpha-transparent background (omitting the geometry behind them). Is the multi-pass render the only way around this?

Thanks,
Andy

bigstick

Avatar / Picture

Moderator
Registered:
Posts: 10,224
Reply with quote  #10 
I'm afraid, that's just the way the render engine works.  Michalis's suggestion of a second render using non-transparent materials might be the best solution.
__________________

That which does not kill us makes us stronger
-Friedrich Nietzsche

sergio3485

Registered:
Posts: 75
Reply with quote  #11 
yes, i also had that same issue since a long time ago. will that be fixed for v2.6?
Nick00

Avatar / Picture

Maître érudit
Registered:
Posts: 3,290
Reply with quote  #12 
No sorry, there are much more important task on our hands right now.
__________________
Podium Tech. Support
zandroos

Registered:
Posts: 14
Reply with quote  #13 
Hi, 

Will this issue be solved in the long expected V3?

Cheers, Alessandro
bigstick

Avatar / Picture

Moderator
Registered:
Posts: 10,224
Reply with quote  #14 
I'm not sure. We would have to experiment to see whether by using slightly different settings, we can achieve the results with V2+
__________________

That which does not kill us makes us stronger
-Friedrich Nietzsche

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.