SU Podium Forum
Register  |   |   |  Calendar  |  Latest Topics

  Author   Comment  

Posts: 2
Reply with quote  #1 
Dear all,
I'm getting the (!!! Unknown symbol) error when trying to render a scene. I believe this might be related to the fact that some elements have been imported from an FBX file. I've renamed all the materials in case that was causing the problem but still same error.

Anybody knows of anything I might be able to do to avoid this problem? Thanks a lot for your help.


Posts: 1,586
Reply with quote  #2 
Unknown symbol message is a symptom of something in the model that Podium can not export properly to it's raytracing engine and therefore makes the rendering process longer than expected. Unknown symbol is a bit of mystery to us and we are working on understanding. We thought the problem was due to a misconfiguration of one of the presets. But it's not limited to that.We know for sure unknown symbol message will appear if you have a Photoshop image in the model (.psd). Also I have seen AutoCAD blocks that have entities that are not coplanar that are imported to SketchUp will create this error message. FBX is a first to me and I didn't know SketchUp would import this format.
But in any case, unknown symbol does not stop the rendering to complete.  It may take longer though.

Posts: 2
Reply with quote  #3 
Thank you very much for the information. I imported the FBX file with a plugin (simLab FBX Importer).

Avatar / Picture

Posts: 10,467
Reply with quote  #4 
Dave's quite right. We know that importing geometry from other modellers can be problematic. SketchUp geometry

Have you tried to run any plugins like Cleanup3 on the model?


That which does not kill us makes us stronger
-Friedrich Nietzsche

Previous Topic | Next Topic

Quick Navigation:

Easily create a Forum Website with Website Toolbox.